Join Regular Classroom : Visit ClassroomTech

Add and Concatenate – Infytq 2019 Solve

Problem: A list of numbers will be given, number 5 and 8 will be present in the problem input. (5 will always come before 8).

Step 1: Add all the numbers which don’t lie between 5 and 8 as given in the input statement (excluding 5 and 8 itself).

Step 2: concatenate all the numbers in between 5 and 8 (including 5 and 8)

Step 3: Sum of value of Step 1 and Step 2.

Sample Input:

3,2,6,5,1,4,8,9

Sample Output:

5168

Explanation:

Step 1: sum of 3,2,6,9 since they doesn’t fall between 5 to 8 (excluding 5 and 8). 3+2+6+9=20

Step 2: concatenation of ‘5’, ‘1’, ‘4’, ‘8’ is 5148

Step 3: 20+5148 = 5168 (Output)

Solution: We strongly recommend you to try the problem first before moving to the solution.

Python

# Code to understand the Add and Concatenation problem in Python
# www.codewindow.in

num=input().split(',')
length=len(num)
indexFive=num.index('5')
indexEight=num.index('8')
sum2 = ''
sum1 = 0

for i in range (indexFive, indexEight+1):
    sum2 += (''.join(num[i]))
    
for i in range (0, length):
    if(i<indexFive or i>indexEight):
        sum1 += int(num[i])

print(sum1+int(sum2))

Input:

3,2,6,5,1,4,8,9

Output:

5168

Follow Us

You Missed